XenApp 5 su Windows 2008…dominio Active Directory 2008.. e i Roaming Profiles?

windows2008Ho fatto numerose installazioni di XenApp 5 su Windows 2008, sia 32 che 64 bit, ma non avevo mai provato l’ambiente in un dominio Active Directory 2008.

Ecco che ho testato anche questa cosa: tutto funzionante… in un primo momento senza utilizzare i roaming profiles….attivati poi in un secondo momento.

E’ da qui che non riuscivo a capire il perchè di numerose stranezze……

Creati gli utenti sul dominio Windows 2008, impostati i roaming profiles e i folder redirection via GPO come sempre, noto una cosa stranissima: aprendo la WebInterface, loggandomi con l’utente e cliccando sull’icona dell’applicazione pubblicata ricevevo il desktop del server Xenapp invece che l’applicazione!!

Problema che non ha una spiegazione chiara: potrebbe essere riconducibile ad un’errata configurazione della share di rete che ospita i roaming profile a livello di NTFS, oppure un problema di profilo corrotto…ho trovato post riguardanti lo stesso problema su Metaframe XP ma risolti con hotfix…..ma io avevo l’ambiente totalmente nuovo e XenApp5!

Dopo numerose indagini e un po’ di tempo per il troubleshooting arrivo a circoscrivere la problematica, come documentato anche da altri utenti, al DOMINIO Windows 2008.

In effetti su dominio Windows 2003 non avevo mai avuto questo tipo di problema.

Come riporta anche questo thread sul forum di supporto Citrix, il problema nasce proprio dal dominio Windows 2008: infatti sembra che editando il campo “Terminal Server User Profile Path” lui vada a scrivere un percorso UNC che risulta illeggibile dalla macchina XenApp.

La cosa mi ha lasciato molto perplesso e per togliere ogni dubbio ho seguito il consiglio del collega sul forum: “prova ad editare l’utente di Active Directory da una macchina Windows 2003, membro del dominio (non Domain Controller) che abbia installato gli adminPack per la gestione del Dominio”

If you use the AD Users & Computers console of Win2K3 or a VBScript to set the TS profile path, published applications are launched as expected.

Fatto questo il mio utente XenApp a iniziato a funzionare correttamente, compreso il suo roaming profile.

Ora noto che la discussione risale a Settembre 2008, che Windows 2008 era al Service Pack 1, che non è un problema di Citrix…la mia domanda allora è:

Ma il problema non è ancora risolto? Devo continuare a gestire gli utenti da una macchina Windows 2003 se ho un dominio AD 2008? L’SP2 sui domain controller risolverebbe? Il problema e di AD quindi esiste anche su RDP ? E’ semplicemente un problema della Console di Active Directory 2008?

Sembra che nessuno ne parli… se avete qualche notizia potete postare un commento.

Grazie

UPDATE: ho trovato un altro con il mio stesso problema! link

Lascia un commento

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.