Errore 0x80041205 Sharepoint 2003 dopo installazione di .NET Framework 2.0


microsoft Oggi mi sono trovato di fronte ad un nuovo problema: installare Framework .Net 2.0 su un server Sharepoint 2003! La cosa non mi dava preoccupazione, fino a quando, dopo l’installazione, ho notato che il sito di sharepoint non autenticava più gli utenti…praticamente era diventato inutilizzabile!

Ho fatto numerose ricerche e sono arrivato al punto di dire che l’installazione di Framework .Net 2.0 ha fatto una specie di Lockdown alle protezioni di Windows Server 2003, rendendo l’autenticazione NTLM o Kerberos in secondo piano rispetto a quella Anonima.

Dopo un paio d’ore di tentativi, e accurate letture in tutti i forum, sono arrivato alla conclusione che:

per far ripartire il sito web bisogna togliere l’autenticazione anonima dal sito di Sharepoint.

Il mio sito prevedeva l’accesso di tutta una serie di utenti active directory, quindi la modifica è stata banale.

Per coloro invece che dovranno usare il portale con gli utenti Anonimi, occorre fare la procedura di reset della password degli utenti IUSR_ e IWAM_ presenti nel Metabase di IIS  e sincronia con Active Directory come spiegato dettagliatamente qui

Aggiornate sia Sharepoint  che Windows all’ultima versione di service pack.

Non so se il problema si presenta anche con .Net Framework 3.5, ma ho letto molti problemi anche con questo, dato che Sharepoint 2003 è basato su web application di Framework 1.1!

Lascia un commento

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.